itsme213 wrote:
> The last instance_variable_set in the following makes irb 0.9 on Ruby 1.8.2
> (2004-11-06) crash on WinXP.
>>irb --version
> irb 0.9(02/07/03)
>>irb
> C:/ruby/lib/ruby/1.8/irb/input-method.rb:97: [BUG] Segmentation fault

I can attest that something is fishy in irb under windows (XP, SP2 if 
that matters).

D:\>irb --version
irb 0.9(02/07/03)
D:\>irb
irb(main):001:0> c:/ruby/lib/ruby/1.8/irb/input-method.rb:97: [BUG] 
Segmentation
  fault
ruby 1.8.2 (2004-11-06) [i386-mswin32]

What I did? I pressed tab twice. My belief is that there is some bug in 
readline, though I am not entiredly certain. Another thing to note is 
that the error doesn't appear on all installations of ruby on windows.