On Thursday 09 December 2004 04:43 pm, Gavin Sinclair wrote:
| Array#compact
|
| It doesn't currently take a parameter, so allow it to take one.  FWIW
| I think Array#delete should be deprecated, and Array#compact extended
| in this fashion.  I don't see a good rationale for the return value of
| Array#delete, and when a method is called #delete there is always
| confusion about whether it's destructive.

Fair assessment. I think I'll go this route then. (Although I'll leave #delete 
defined, and just generally forget it's even there ;)

| Ruby spoils us so much that when you have to look something up in the
| docs a few times you feel cheated :)

LOL. Too true.

Thanks,
T.