On Thursday, December 9, 2004, 2:47:29 AM, Erik wrote:

>> Will this support all manner of 'require'd files, including
>> those loaded by the gems require-hack?

> [......]

> ----------------------------------------------------------------
> 
>  # Doesn't work.
> 
>  require 'rubygems'
>  require_gem 'progressbar'
> 
> ----------------------------------------------------------------
> 
>  # Does work.
> 
>  require 'rubygems'
>  begin
>    require_gem 'progressbar'
>  rescue Gem::LoadError
>    require 'progressbar'
>  end
> 
> ----------------------------------------------------------------

Try:

  require 'rubygems'
  require 'progressbar'

Cheers,
Gavin