itsme213 wrote:

> I was talking about the pure object model part of Ruby. In such a pure
> object model, a[1] and a[2] are instance variables (some Smalltalk
> descriptions calls these 'indexed instance variables' as opposed to 'named
> instance variables'). How something is optimized in C is a different matter.

Please call this Object state ("as in a[1] and a[2] are part of Object 
state" / "@foo is part of Object state") instead. It's a more general 
term and seems to already be well-established.