What's the proper way to uninstall RubyGems?

If you wonder why I'd want to:
  1. Screwy error messages.
  2. RUBYOPT causes conflict with RPA and compiling Ruby.
  3. I like setup.rb best anyway.

What I like about it that I will miss?
  1. Command line interface is well done.
  2. Version control is a very nice feature.
  3. Love the name.

Unfortunately the later doesn't quite overcome the former, at least for my 
tastes.

Thanks,
T.