I compiled and installed fox-1.2.11 on my SUSE-Linux machine.
(My Ruby installation: ruby 1.8.2 (2004-11-06) [i686-linux])

Then i tried to build FXRuby-1.2.2:
ruby install.rb config
ruby install.rb setup

but gcc fail with the following message:

g++ -fPIC -g -O2 -O0 -Iinclude -DWITH_FXSCINTILLA   -I. 
-I/usr/lib/ruby/1.8/i686-linux -I/usr/lib/ruby/1.8/i686-linux 
-I/home/stefan/Ruby/lib/FXRuby-1.2.2/ext/fox12 -DHAVE_SYS_TIME_H 
-DHAVE_SIGNAL_H -I/usr/local/include/fxscintilla -I/usr/local/include/fox-1.2  
-c FXRuby.cpp
FXRuby.cpp:64: error: declaration of C function `void st_foreach(st_table*, 
int
   (*)(char*, char*, char*), char*)' conflicts with
/usr/lib/ruby/1.8/i686-linux/intern.h:249: error: previous declaration `void
   st_foreach(st_table*, int (*)(), long unsigned int)' here
make: *** [FXRuby.o] Fehler 1
setup failed
'system make ' failed

This is the third GUI toolkit for Ruby i try to install.
Korundum (KDE bindings) doesn't compile
and the same with ruby-FLTK.

Has anyone out there already used one of those GUI toolkits
one a SUSE (9.1) machine?

Thanks in advance,
Stefan
(Excuse me for my "broken" English ;)