Im very confused by whats happening with rmagic and rubygem. Now, Im
the first to admit that i didnt read much in the way of the
installation instructions.

Ive got gems installed , 0.8.1 on windows
Ive installed rmagic with the gem:

C:\>gem list

*** LOCAL GEMS ***

RMagick-win32 (1.6.0)
    RMagick is an interface between the Ruby programming language and
    the ImageMagick and GraphicsMagick image processing libraries.

sources (0.0.1)
    This package provides download sources for remote gem installation


now, the rmagic sample use require 'RMagick'
which gives me:
C:/ruby/lib/ruby/gems/1.8/gems/RMagick-win32-1.6.0-mswin32/doc/ex/border.rb:2:in
`require': No such file to load -- RMagick (LoadError)
        from C:/ruby/lib/ruby/gems/1.8/gems/RMagick-win32-1.6.0-mswin32/doc/ex/border.rb:2

If I change to :
 require 'rubygems'
  require_gem 'Rmagic'

I get
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:121:in `activate': 
(Gem::LoadError)
RubyGem version error: RMagick(1.6.0 not > 0.0.0)
        from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:34:in
`require_gem'
        from C:/ruby/lib/ruby/gems/1.8/gems/RMagick-win32-1.6.0-mswin32/doc/ex/border.rb:6

I can copy the rmgic.rb and rmaigic.so to C:\ruby\lib\ruby\1.8 and the
samples work.

Thanks

Paul