If you can wait about a week, we're currently testing FreeRIDE 0.9.0 and
will release it very soon, and I think it should take care of the debugger
problems. Probably within a day of the FreeRIDE release I will release an
updated version of the One-Click Installer that includes FreeRIDE 0.9.0 --
the current installer is a version behind because I had debugger problems
with 0.8.0 in the one-click installer.

If you can wait, you could get the most recent version of FreeRIDE from cvs.

Also, one more thing you can try... You might have an incompatible or
corrupted freeride configuration file in your user directory. Go to
%USERPROFILE% and delete the "freeride" subdirectory (it will be re-created
the next time you run FreeRIDE). Its possible that this could fix your
problem.

Curt

> -----Original Message-----
> From: tony summerfelt [mailto:snowzone5 / hotmail.com]
> Sent: Thursday, November 25, 2004 5:19 PM
> To: ruby-talk ML
> Subject: oneclick installer, freeride
>
>
> anybody NOT developing the oneclick installer or  freeride can skip
> this...
>
> in my quest for debugging ruby via ide i used the one click installer
> (ruby182-14RC9.exe)
>
> i installed in directory g:\ruby.1.8.2\ruby
>
> on running run.bat i get the following
>
> ruby freeride.rb
> Failing to load: rubyide_fox_gui-appframe
>
> [195 more 'failing to load errors deleted for brevity]
>
> Failing to start: rubyide_tools_configurator
> Failing to load: RRB
> Failing to start: RRB
>
> thinking it might be a path problem i ran with a known path to ruby
> (..\bin\ruby freeride.rb)
>
> the following errors
>
> src/emitter.rb:945:in `const_get': uninitialized constant
> Scintilla::EmptyStyle (NameError)
>         from src/emitter.rb:945:in `read_type_class'
>         from src/emitter.rb:944:in `each'
>         from src/emitter.rb:944:in `read_type_class'
>         from src/emitter.rb:1494:in `module_eval'
>         from src/emitter.rb:1493:in `call'
>         from src/emitter.rb:1028:in `transfer_method'
>         from src/yaml.y.rb:651:in `attach_transfer'
>         from src/yaml.y.rb:42:in `_reduce_11'
>          ... 16 levels...
>         from
> G:/ruby.1.8.2/ruby/freeride/freebase/lib/freebase/core.rb:35:in
> `new'
>      from
> G:/ruby.1.8.2/ruby/freeride/freebase/lib/freebase/core.rb:35:in
> `startup'
>         from freeride.rb:80:in `startup'
>         from freeride.rb:92
>
>
> so giving up on the one click installer version of freeride for a bit
> i installed freeride from the installer
> (freeride-win-installer-0.8.0.exe)
>
> THAT fired up ok :)
>
> but because i don't like white (or any light background) first thing i
> do with any editor/ide is change to the colour scheme i'm most used
> to...i can change 3 or 4 colours before the 'freeride went south'
> window comes up with an unhandled exception...i can do this
> consistently...if necessary i can report the output to the bug tracker
>
> and on clicking on Run->debugger the 'freeride went south'   comes up
> again: the first line in the window is (it was all on one line):
>
> No such file or directory - g:\ruby\freeride\freeruby-win\bin\ruby.exe
> -C "r:/code/.rb" -r "drb" -r
> "G:/ruby.1.8.2/FreeRIDE/plugins/rubyide_tools_debugger/debuggee.rb"
> "r:/code/.rb/logr.rb"
>
> the code i'm editing is in the r:/code/.rb directory
> http://home.cogeco.ca/~tsummerfelt1
> telnet://ventedspleen.dyndns.org
>
> ---
> Incoming mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.799 / Virus Database: 543 - Release Date: 11/19/2004
>