Hi,

In message "[ruby-talk:12097] RCR: replacing 'caller'"
    on 01/03/06, Robert Feldt <feldt / ce.chalmers.se> writes:

|IMHO, 'caller' would be much more useful if you could know/access the
|method and object that called you. Therefore I submit this RCR:
|
|Replace 'caller' with 'call_stack' returning an array of arrays each with
|the format:
|
|[object_called, method_called_id, args, file_with_call, line_for_call]
|
|'call_stack' takes a level parameter (almost) in the same way as 'caller'. 

Hmm, do you think call_stack is the best name?
I'd happy to merge this patch if my name concern resolved.

							matz.