On Wednesday 10 November 2004 07:53 am, Jonathan Paisley wrote:
| Is the SyncEnumerator method 'end?' from the original implementation in
| generator.rb part of the public interface? If so, is it okay that the
| proposed alternative doesn't provide it?

Speaking of which, I tend to think #begin and #end, and the like named methods 
make terrible method names. Do others agree? Should these be dprecated in 
favor of others?

T.