On Friday, October 22, 2004, 7:44:07 AM, David wrote:

>> I finally decided I had the time to try out the Rails framework, so I
>> went to install it via rubygems. All the dependencies installed fine,
>> but I got an error when it tried to install the rails gem itself.

> Are you running Ruby 1.9? Rails 0.7 has a problem that. It should be
> fixed in the upcoming release among a thousand other things. It's okay
> to hold your breath. "Real soon now", he said :)

You can make that clear in the gemspec (untested):

  spec.required_ruby_version = ['> 1.8.1', '< 1.9.0']

That would help avoid the problem, if that's the cause here.

Cheers,
Gavin