/data/ruby/bin/ruby -v         
ruby 1.8.2 (2004-10-19) [sparc-solaris2.8]

gives the following error

data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:74:in `new_from_stream': method `unpack' called on terminated object (0x3c4c80) (NotImplementedError)
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:439:in `each_entry'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:437:in `loop'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:437:in `each_entry'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:422:in `each'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:527:in `each'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:526:in `new'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:526:in `each'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/package.rb:522:in `each_entry'
         ... 8 levels...
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/format.rb:41:in `from_file_by_path'
        from /data/ruby/lib/ruby/site_ruby/1.8/rubygems/installer.rb:46:in `install'
        from install.rb:144:in `install_rb'
        from install.rb:148

This happens on win32 ruby (same version) as well,
so the bug is platform independent.

this bug is caused by the latest change to zlib.c.  
if I do

cvs diff -u -r1.7.2.7 -r 1.7.2.6 zlib.c > zlib.patch
patch < zlib.patch

rubygems installs ok. So either rubygems do not use zlib correctly or this
change is invalid.

 - Ville