On Wed, 13 Oct 2004 16:54:34 +0900, gabriele renzi
<rff_rff / remove-yahoo.it> wrote:
> George Moschovitis ha scritto:
> 
> >
> > Btw It would be nice if the error was more helpful, ie something like:
> >
> > This gem was packaged by another version
> >
> > or something...
> >
> 
> I think that dtermining a version mismatch from this error would be
> quite hard...
> But it could be useful if when getting remote gems the rubygems
> application checked that it version was the latest one.
> 

In future RubyGems versions, we can do this.  The problem is that
0.7.0 never imagined that 0.8.0 would come along and change its
format.  So as far as 0.7.0 knew, the new gems were corrupt.  We can
change this for later releases, but we can't fix 0.7.0 without having
people upgrade.

In short, I agree ;)

Chad