i seem to recall having to install libiconv, flex, bison...not sure if
this made a difference
also run gmake
i have the latest stable build of Ruby running on 
OpenBSD 3.5