Yes, I am aware that this has come up before.  I have tried all past
suggestions that I can find archived, however, and I am still at a
frustrating impasse.  Running Mac OS 10.3.5 with developer tools
installed, I have tried installing Ruby 1.8.1 both from available
package, as well as building myself from source.  Readline appears
installed, and indeed works fine for other applications (psql client
for postgres, for example - or even Ruby 1.6.8 works fine).  Readline
module compilation reports success during Ruby 1.8.1 build.

Even so, `ruby -rreadline -e'print'` returns:

dyld: ruby can't open library:
/System/Library/PrivateFrameworks/readline.framework/Versions/A/readline
(No such file or directory, errno = 2)
Trace/BPT trap

Given the "No such file" message, I added a symlink named 'readline' to
/usr/lib/libreadline.dylib under
/System/Library/PrivateFrameworks/readline.framework/Versions/A/ -- but
still get the same error.

Any help or further suggestions much appreciated.  Does anybody out
there have a working readline.bundle compiled under 10.3.5?
Thanks,
Thomas Yager-Madden
http://syntactician.com