Requiring mathn generates warnings under -w.  I would hope that the 
standard libraries are quiet unless I have done something awful in my 
code. 

[mike@ratdog 025]$ uname -a
Linux ratdog.stok.co.uk 2.6.3-16mdk-i686-up-4GB #1 Fri Aug 13 15:13:56 MDT 2004 i686 unknown unknown GNU/Linux
[mike@ratdog 025]$ ruby -v -e 'require "mathn"'
ruby 1.8.2 (2004-10-02) [i686-linux]
/usr/local/mike/ruby-stable/lib/ruby/1.8/mathn.rb:19: warning: method redefined; discarding old gcd2
/usr/local/mike/ruby-stable/lib/ruby/1.8/mathn.rb:119: warning: method redefined; discarding old inspect
/usr/local/mike/ruby-stable/lib/ruby/1.8/mathn.rb:231: warning: method redefined; discarding old sqrt

The link to browse the bug database
http://www.ruby-lang.org/cgi-bin/ruby-bugs on
http://rubyhacker.com/clrFAQ.html doesn't seem to work, so I appologise if
this is a duplicate report.

Mike

-- 
mike / stok.co.uk                    |           The "`Stok' disclaimers" apply.
http://www.stok.co.uk/~mike/       | GPG PGP Key      1024D/059913DA 
                                   | Fingerprint      0570 71CD 6790 7C28 3D60
                                   |                  75D2 9EC4 C1C0 0599 13DA