"Yukihiro Matsumoto" <matz / ruby-lang.org> schrieb im Newsbeitrag
news:1096592771.410462.16363.nullmailer / x31.priv.netlab.jp...
> Hi,
>
> In message "Re: ruby-dev summary 24298-24353"
>     on Fri, 1 Oct 2004 09:52:34 +0900, "trans.  (T. Onoma)"
<transami / runbox.com> writes:
>
> |> Hmm, "fanctor".  I like the name.
> |
> |Is a new class required? I think, Proc could add this feature and
remain
> |backward compatible.
>
> I just said I liked the name. ;-)
> I'm not yet sure if we need a new class.

What about the Adaptor idea I posted on 30.9.  Somehow nobody seems to
have noticed.  I'll repost the core part below.

    robert