Zach Dennis wrote:

> You added more syntax then needed. "-" has higher precendence then "...".
>
> (0..x.size-1).each
>
> That appears quite clean and it only one more character then:  
> (0...x.size).each
>
And it makes more sense when reading it.