On Mon, 2004-09-27 at 06:12 +0900, Matt Lawrence wrote:
> I'm trying to find rpms for the latest released version of Ruby.  After I 
> pulled ruby-1.8.1-9.i386.rpm off of rubyforge, I tried to install it and 
> ran into missing dependecies libruby.so.1.8 & ruby-libs = 
> 20040219:1.8.1-9.

I highly reccomend compiling from source RPMs if the distro the RPM was
built for is not your own.

Snag a .src.rpm, rpm --rebuild srpmfile -- you should get binaries.

If you want to tweak it, rpm -i srpmfile, then find the spec it spit out
(usually ruby.spec if the package name is ruby), edit the version
numbers, drop the source in the SOURCES directory, and then rpmbuild -ba
ruby.spec

Very useful, and since it was compiled on your distro, the dependencies
should resolve perfectly.