Hi,

In message "Re: Array#index block and rdetect"
    on Tue, 21 Sep 2004 20:33:52 +0900, "trans.  (T. Onoma)" <transami / runbox.com> writes:

|For sake of interchangeability (after all that's the upside of ducktyping) 
|have an alias for both:

Arrays have number index, and hashes have arbitrary type of keys, so
that there should hardly be the case of need for interchangeability
between them.  Do you have any example of the usage?

Currently, I'd rather feel that it's good to avoid the term "index"
for hashes, for example, renaming IndexError to KeyError for Hash
class.


							matz.