Hi --

On Mon, 13 Sep 2004, trans.  (T. Onoma) wrote:

> On Sunday 12 September 2004 02:19 pm, Martin DeMello wrote:
> > "trans.  (T. Onoma)" <transami / runbox.com> wrote:
> > > > Good!  I'd just put it into class Object instead of module Kernel. 
> > > > That's a more appropriate place IMHO.  Also "metaclass" seems the wrong
> > > > term in this case, although I can see why you didn't want to use
> > > > "singleton_class"...
> > >
> > > Agreed. Better name?
> >
> > selfclass?
> 
> That's better. Or maybe self_class.

Then you have "self.class" and "self.self_class" -- or, for that
matter, potentially "self.class" and "self_class" -- meaning different
things but looking awfully similar.  

I think Matz is actually migrating from 'singleton class' to 'virtual
class'.  I don't like that term very much (there's nothing really
"virtual" about it; it's a real class, once it's created, and if it's
not created, it's not even virtual), but it's probably a good idea to
keep the terminology unified.  


David

-- 
David A. Black
dblack / wobblini.net