On Sep 10, 2004, at 10:47 PM, Zach Dennis wrote:

> Maybe I should just go to bed....I think I will.....because I can't 
> find where it says how-to compile libapreq for use with mod_ruby and 
> the libapreq for apache 1.3 download only gives instructions to 
> compile and install with mod_perl.....and I dont want to install 
> mod_perl unless i have to. Any ideas on this one?

I'm not sure about platforms other than MacOS X, Linux, and FreeBSD (as 
those are the only machines I use), but on all three of those 
installing libapreq was just a matter of following the instructions at 
the bottom of INSTALL:

   Alternatively, to build and install a shared version
   of libapreq using GNU libtool, do this:

    ./configure --with-apache-includes=DIR && make && make install

> Also on line 44 of the install.rb file in the Test-Unit-Mock-0.0.3 
> directory....there is a complaint from ruby. It has to do with 
> comparison of strings against regexp....in case the Arrow guys want to 
> check this out.....I am running ruby 1.8.2 now.... ;)

It's been fixed in the development version of Test::Unit::Mock, but 
since it's just a warning, I haven't packaged up a release for it. It 
should install fine despite the warning; please do let me know if such 
is not the case.

--
Michael Granger <ged / FaerieMUD.org>
Rubymage, Believer, Architect
The FaerieMUD Consortium <http://www.FaerieMUD.org/>
12383406064495388618631689469409153107.to_s(36).tr('z',' ')