On Fri, 2004-09-10 at 20:55, gabriele renzi wrote:
> I have a strange behaviour I can't explain

I have the same behavior on Linux. Don't have time too look at the root
cause right now, but it's nothing to do with the platform.

Alex


[alex@dhcp-89-2 alex]$ ruby -v
ruby 1.8.2 (2004-07-29) [i686-linux]
[alex@dhcp-89-2 alex]$ ruby boom.rb
Loaded suite boom
Started
Fboom.rb:6:in `testException': Exception (Exception)
        from /usr/local/lib/ruby/1.8/test/unit/testcase.rb:70:in
`__send__'
        from /usr/local/lib/ruby/1.8/test/unit/testcase.rb:70:in `run'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:32:in `run'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:31:in `each'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:31:in `run'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:32:in `run'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:31:in `each'
        from /usr/local/lib/ruby/1.8/test/unit/testsuite.rb:31:in `run'
        from
/usr/local/lib/ruby/1.8/test/unit/ui/testrunnermediator.rb:44:in
`run_suite'
        from
/usr/local/lib/ruby/1.8/test/unit/ui/console/testrunner.rb:65:in
`start_mediator'
        from
/usr/local/lib/ruby/1.8/test/unit/ui/console/testrunner.rb:39:in `start'
        from
/usr/local/lib/ruby/1.8/test/unit/ui/testrunnerutilities.rb:27:in `run'
        from /usr/local/lib/ruby/1.8/test/unit/autorunner.rb:185:in
`run'
        from /usr/local/lib/ruby/1.8/test/unit/autorunner.rb:13:in `run'
        from /usr/local/lib/ruby/1.8/test/unit.rb:283
        from /usr/local/lib/ruby/1.8/test/unit.rb:283