Gavin Kistner <gavin / refinery.com> wrote:
: I'm trying to get Ruby/OpenGL working for just me on my MacOS X box; 
: I've looked at various things people have helpfully written in the past 
: on the topic ( ruby-talk:89025 ) but unfortunately that was then, and 
: the instructions don't seem to work for me on the current version of 
: the opengl library.

: I'd really appreciate it if someone who has Ruby/OpenGL working on 
: Panther could write up a set of instructions for dummies; not just "you 
: might want to get the Apple GLUT src" but "Here's a url to the GLUT 
: src; download it, and run ... to get it compiled BEFORE the next step." 
: Or whatever.

It would be nice if there were a binding that didn't use GLUT, because for
the most part it's unnecessary.

btw, I have similar issues with the ruby opengl bindings on Linux (I'm using
accelerated non mesa openGL on my box), and I just gave up trying to get
this to work properly.

To be fair, most scripting languages have issues with vendor supplied
openGL libs.


: I really did try to apply the hacks listed in that thread to the 
: current (0.32f) source, but I simply have no idea what I'm doing when 
: it comes to getting other's packages to compile properly.

: Help, please? :)
: --
: (-, /\ \/ / /\/