On Tue, 20 Feb 2001, Jean Michel wrote:

> I like to consider an array conceptually as a special case of hash where
> the keys are restricted to be positive integers. So I am very opposed to
> choices which  make them differ  more than  necessary (in the  spirit of
>
I fully agree with this and would like to add that its easier to learn one
method name than two...

> >> >   (a) Hash#values, Array#values
> >> >   (b) Hash#values_for, Array#values_for
> >> >   (g) Hash#selections, Array#selections
> >> >   (h) Hash#collect_indexes, Array#collect_indexes
> >> >   (f) Hash#subset, Array#subset
> 
but I'd vote for Hash#elements_at/Array#elements_at or
Hash#elements/Array#elements.

Regards,

Robert