nobu.nokada / softhome.net wrote:
> At Sat, 28 Aug 2004 03:43:39 +0900,
> Bil Kleb wrote in [ruby-talk:110682]:
> 
>>During compile of the 08-26-2004 stable snapshot, I get a warning:
>>
>>  gcc -g -O2   -I. -I.  -c eval.c
>>  eval.c: In function `massign':
>>  eval.c:4912: warning: cast from pointer to integer of different size
>
> I think that it is fixed in CVS already.  This is the backport.

Thanks for the patch.  However, I am still getting a segmentation fault in
exactly the same manner as reported in the original message.

FWIW, I received the following data from the NASA sysadm folks:

  Here is an update on building ruby.

  One of our sysadms [..] and I tried a few
  experiments on building Ruby on our Altix machines.
  We tried different combinations
  of (1) two versions of OS, one with SGI ProPack2.4,
  the other with SGI ProPack3.0, (2) different versions of
  c compilers, gcc.2.96, gcc.3.2.3, gcc.3.3.1 and Intel ecc 7.0.27,
  (3) two versions of Ruby, 1.8.1 and 1.8.2-preview.
  Unfortunately, none of them succeeded.

  (1) ruby-1.8.1, gcc 2.96,
      OS 2.4.21-sgi240rp04080615_10094 #1 SMP
      (SGI ProPack 2.4) make -> segmentation fault

  (2) ruby-1.8.2-preview2, gcc 2.96,
      OS 2.4.21-sgi240rp04080615_10094 #1 SMP
      (SGI ProPack 2.4) make -> segmentation fault

  (3) ruby-1.8.2-preview2, gcc 3.2.3
      OS 2.4.21-sgi240rp04080615_10094 #1 SMP
      (SGI ProPack 2.4) make failed

  (4) ruby-1.8.1, gcc 2.96,
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0)  make stuck

  (5) ruby-1.8.1, gcc 3.2.3
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0) make stuck

  (6) ruby-1.8.1, gcc 3.3.1
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0) make with error

  (7) ruby-1.8.1, ecc 7.1.027
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0) make with error

  (8) ruby-1.8.2, gcc 3.2.3
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0) make with error

  (9) ruby-1.8.2, gcc 3.3.1
      OS 2.4.21-sgi300rp04081111_10096
      (SGI ProPack 3.0) make with error

  On the contrary, I also asked one of my colleagues
  to test building Ruby on his Linux workstation, it built
  just fine.

  ruby-1.8.2-preview2 built successfully
  using gcc.3.2.3 and the following Linux OS
  Linux [..] 2.4.21-15.0.3.EL #1

Regards,
-- 
Bil, Hampton, Virginia