> I have to admint `indexes' is not good name, since its behavior
> (returning values corresponded to keys/indexes) not consistent with
> one of `index' (returning key/index of value).
> 
> Let's face it.

                                                   
The explanation of Hash#indexes at
http://www.rubycentral.com/ref/ref_c_hash.html#indexes
says:

  Returns a new array consisting of values for the given key(s).
  Will insert the default value for keys that are not found.

So Hash#values_for is probably the best descriptive name.

Paul.