"Austin Ziegler" <halostatue / gmail.com> schrieb im Newsbeitrag
news:9e7db91104082311481dae7133 / mail.gmail.com...

> The idea of having #gsub with the flag (as opposed to the #gsubm [the
> name I had chosen instead of #gsub_md) form which I rejected in
> writing my response to Nobu) is that IMO we should encourage the use
> of the new form with MatchData objects, not the other form. By using
> #gsubm, we discourage the use of the new form in favour of the old
> form. The only way that I think that this would really work is to have
> #gsub yield MatchData and #gsubs yield Strings, if we take that
> approach. --AustinZiegler

Please bear in mind that the new form is not appropriate in all cases.  For
some applications it comes very handy that those mehtods yield a String.  So
although I like the new methods (that yield MatchData) and would really like
to see them one way or another in Ruby, I merely see them as complement to
the existing set of methods.  For me there is no urge to encourage usage of
the new form and / or phase out the old methods.  I'd rather have both of
them available with separate names so I can freely choose from them
whichever variant is best in a certain situation.

Kind regards

    robert