> Or even easier, just do "gem install rails" -- you'll automatically  
> install all the newest versions of the required dependencies.

Doesn't quite install under cygwin.

ruby 1.9.0 (2004-08-17) [i386-cygwin]
gem 0.7.0

robertm@al ~
$ gem install rails
Attempting local installation of 'rails'
Local gem file not found: rails.gem
Attempting remote installation of 'rails'
Install required dependency rake? [Yn]   y
Install required dependency activerecord? [Yn]   y
Install required dependency actionpack? [Yn]   y
ERROR:  While executing gem ... (NameError)
    (eval):1:in `class_eval': uninitialized class variable @@inheritable_attributes_for_base in CGI::Session::ActiveRecordStore::Session