That most likely is a FOX 1.2.x library, when I was
hacking at the code to work nice with FOX 1.0.x, that
was the error I did get. Something is wrong with
FXMenuBar :) 

--- Simon Strandgaard <neoneye / adslhome.dk> wrote:

> On Sunday 15 August 2004 11:08, Meino Christian
> Cramer wrote:
> >  I got some problems here after installing aeditor
> 1.5.
> >
> >  config,setup and installing were clean but right
> after start of
> >  eaditor I got:
> >
> >   [aeditor-1.5/] :aeditor
> >   did not found a configuration file
> >   spawning editor in window mode.
> >  
>
/usr/lib/ruby/site_ruby/1.8/aeditor/viewfox.rb:286:in
> `initialize':
> > uninitialized constant EditorWidget::FXMenubar
> (NameError) from
> [snip backtrace]
> >
> >  I _thought_ I have installed everything needed,
> but...
> 
> Hmm.. I suspect you maybe have a different version
> of fox.. did you install 
> Fox 1.2.x ?    
> 
> AEditor 1.5 doesn't work with the Fox 1.2.x  (but
> its on my todo).
> 
> Please chect the version numbers of aeditors
> dependencies.
> 
> bash-2.05b$ aeditor -v
> versions:
>   editor           "1.5"
>   fox toolkit      "1.0.43"
>   fxruby           "1.0.25"
>   iterator         "0.8"
>   ruby             "1.8.1"
> 
> other info:
>   platform         "i386-linux-gnu"
> bash-2.05b$
> 
> 
> Thanks for the report.
> 
> --
> Simon Strandgaard
> 
> 

-------------------------------------------
-- Name: David Ross
-- Phone: 865.539.3798
-- Email: drossruby [at] yahoo.com
-------------------------------------------


		
__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail