djberg96 / hotmail.com (Daniel Berger) writes:

> Hi all,
> 
> Ruby 1.8.2-7a
> Instiki 0.9.1
> Windows XP Pro
> 
> I tried running Instiki on my Windows XP box.  It seemed to start
> fine, but as soon as I try to fire up a web browser and view
> "http://localhost:2500", I get a bunch of spewage:
> 
> C:\ruby\src\instiki-0.9.1>ruby instiki.rb
> [2004-08-13 08:52:48] INFO  WEBrick 1.3.1
> [2004-08-13 08:52:48] INFO  ruby 1.8.2 (2004-07-29) [i386-mswin32]
> [2004-08-13 08:52:48] INFO  Your WEBrick server is now running on
> http://localho
> st:2500
> [2004-08-13 08:52:48] INFO  WEBrick::HTTPServer#start: pid=1888
> port=2500
> [2004-08-13 08:53:02] INFO  Performing index
> [2004-08-13 08:53:02] INFO    Parameters: {}
> [2004-08-13 08:53:02] INFO    Cookies:
> [2004-08-13 08:53:02] ERROR Errno::ENOENT: No such file or directory -
> C:/ruby/s
> rc/instiki-0.9.1/storage/2500
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine.rb:327:in
>  `mkdir'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine.rb:327:in
>  `ensure_directory_exists'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine.rb:322:in
>  `initialize'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine.rb:43:in
> `new'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine.rb:43:in
> `new'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine/automatic
> ..rb:159:in `initialize'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine_service.r
> b:52:in `new'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine_service.r
> b:52:in `initialize'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine_service.r
> b:24:in `new'
>         C:/ruby/src/instiki-0.9.1/app/models/../../libraries/madeleine_service.r
> b:24:in `instance'
>         C:/ruby/src/instiki-0.9.1/app/controllers/wiki.rb:291:in
> `wiki'
>         C:/ruby/src/instiki-0.9.1/app/controllers/wiki.rb:10:in
> `index'
>         C:/ruby/src/instiki-0.9.1/libraries/action_controller_servlet.rb:126:in
> `send'
>         C:/ruby/src/instiki-0.9.1/libraries/action_controller_servlet.rb:126:in
> `perform_action'
>         C:/ruby/src/instiki-0.9.1/libraries/action_controller_servlet.rb:32:in
> `
> do_GET'
>         c:/ruby/lib/ruby/1.8/webrick/httpservlet/abstract.rb:35:in
> `__send__'
>         c:/ruby/lib/ruby/1.8/webrick/httpservlet/abstract.rb:35:in
> `service'
>         c:/ruby/lib/ruby/1.8/webrick/httpserver.rb:92:in `service'
>         c:/ruby/lib/ruby/1.8/webrick/httpserver.rb:54:in `run'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:150:in `start_thread'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:144:in `start'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:144:in `start_thread'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:94:in `start'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:89:in `each'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:89:in `start'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:79:in `start'
>         c:/ruby/lib/ruby/1.8/webrick/server.rb:79:in `start'
>         C:/ruby/src/instiki-0.9.1/libraries/web_controller_server.rb:79:in
> `star
> t_server'
>         C:/ruby/src/instiki-0.9.1/libraries/web_controller_server.rb:22:in
> `init
> ialize'
>         instiki.rb:58:in `new'
>         instiki.rb:58
> 127.0.0.1 - - [13/Aug/2004:08:53:02 Mountain Daylight Time] "GET /
> HTTP/1.1" 500
>  346
> - -> /
> 
> From the web page:
> 
> Internal Server Error
> No such file or directory - C:/ruby/src/instiki-0.9.1/storage/2500
> WEBrick/1.3.1 (Ruby/1.8.2/2004-07-29) at localhost:2500
> 
> Any ideas?

I had the same problem on Linux.  If I recall correctly, I fixed it by
just creating the storage directory.

  mikael