I am having the same problem wth socket installing on AIX 4.3.

No errors during compile.

If I go into the ext/socket directory and run

ruby extconf.rb
make

I get

Target "all" is up to date.
Target "install" is up to date.

However, looking at mkmf.log I am getting a lot of errors similar to
the following:

have_library: checking for t_open() in -lnsl... -------------------- no

"gcc -brtl -bI:/fs_export/home_dirs/amoody/ruby/ext/socket/ruby.imp
-bM:SRE -T512 -H512  -oconf
test -I/fs_export/home_dirs/amoody/ruby/ext/socket
-I/usr/local/lib/ruby/1.8/powerpc-aix4.3.3.0
-g -O2 conftest.c  -L"/usr/local/lib"   -lruby-static -lnsl  -ldl
-lcrypt -lm   -lc"
gcc: unrecognized option `-H512'
gcc: installation problem, cannot exec `cpp': A file or directory in
the path name does not exi
st.
gcc: file path prefix
`/opt/freeware/GNUPro/lib/gcc-lib/M:SRE/2.9-aix51-020209/' never used
checked program was:

Any ideas?