On Tue, Aug 10, 2004 at 02:41:46AM +0900, Joel VanderWerf wrote:
> 
> This seems to happen for anything I try to install with rpa:
> 
> # rpa install ri-rpa
> Installing ports
> Getting port ri-rpa from 
> http://rpa-base.rubyforge.org/ports/ri-rpa_0.1-4.rps.
> 100% [========================================] 264704 bytes
> Error: unrecognized arguments ri-rpa aborting

This is very strange, cause

batsman@tux-chan:/tmp/ruby1.9/lib$ grep -r "unrecognized" *
getoptlong.rb:    set_error(InvalidOption, "unrecognized option `#{argument}'")
open-uri.rb:        raise ArgumentError, "unrecognized option: #{k}"

batsman@tux-chan:~/src/rpa/rpa-base$ grep -r "unrecognized" *
lib/rpa/.svn/text-base/open-uri.rb.svn-base:        raise ArgumentError, "unrecognized option: #{k}"
lib/rpa/open-uri.rb:        raise ArgumentError, "unrecognized option: #{k}"

I don't know where that "unrecognized arguments" comes from.

> Versions:
> 
> # rpa -v
> rpa (rpa-base 0.2.0-21) RPA 0.0
> # ruby -v
> ruby 1.9.0 (2004-07-29) [i686-linux]

Can't reproduce it :(

batsman@tux-chan:/tmp/ruby1.9$ ~/ruby1.9/bin/ruby -v
ruby 1.9.0 (2004-08-09) [i686-linux]
batsman@tux-chan:/tmp/ruby1.9$ ~/ruby1.9/bin/rpa install ri-rpa
Installing ports
Getting port ri-rpa from
http://rpa-base.rubyforge.org/ports/ri-rpa_0.1-4.rps.
100% [========================================] 264704 bytes
Building ri-rpa (0.1-4).
Building dependencies rdoc.
Getting port rdoc from
http://rpa-base.rubyforge.org/ports/rdoc_1.8.1-3.rps.
100% [========================================] 94208 bytes
Building rdoc (1.8.1-3).
Calculating MD5 digests.
Building package in rdoc_1.8.1-3_i686-pc-linux-gnu.rpa.
Fixed shebang in rpa/tmp/bin/ri-rpa.
Calculating MD5 digests.
Building package in ri-rpa_0.1-4_i686-pc-linux-gnu.rpa.
  Installing ri-rpa
Reusing cached package
/home/batsman/ruby1.9/lib/ruby/rpa0.0/packages/ri-rpa_0.1-4_i686-pc-linux-gnu.rpa.
Installing dependencies rdoc.
Starting lightweight (metadata only) transaction for ri-rpa
Reusing cached package
/home/batsman/ruby1.9/lib/ruby/rpa0.0/packages/rdoc_1.8.1-3_i686-pc-linux-gnu.rpa.
Starting lightweight (metadata only) transaction for rdoc
Checking for file conflicts in rdoc.
Starting transaction for rdoc
Package
/home/batsman/ruby1.9/lib/ruby/rpa0.0/packages/rdoc_1.8.1-3_i686-pc-linux-gnu.rpa unpacked.
Finished transaction for rdoc
Finished lightweight (metadata only) transaction for rdoc
Checking for file conflicts in ri-rpa.
Starting transaction for ri-rpa
Package
/home/batsman/ruby1.9/lib/ruby/rpa0.0/packages/ri-rpa_0.1-4_i686-pc-linux-gnu.rpa unpacked.
Finished transaction for ri-rpa
Starting lightweight (metadata only) transaction for ri-rpa
Finished lightweight (metadata only) transaction for ri-rpa
Finished lightweight (metadata only) transaction for ri-rpa
Committed changes
  


-- 
Running Debian GNU/Linux Sid (unstable)
batsman dot geo at yahoo dot com