matz / zetabits.com wrote:
>I have to admint `indexes' is not good name, since its behavior
>(returning values corresponded to keys/indexes) not consistent with
>one of `index' (returning key/index of value).
>
>I decided to declare them obsolete and give proper new names in the
>future (1.7 and forth coming 1.8/2.0).  Do you have any idea of good
>name for them?

Excellent.

My initial thought would be to merge that 
functionality into the existing Hash#values 
method. If you pass keys to #values, you would 
get those values. If you pass nothing, you would 
get all values.

If that's not practical, then values_of seems 
reasonable. 

Kevin