>From: matz / zetabits.com (Yukihiro Matsumoto)
>Reply-To: ruby-talk / ruby-lang.org
>To: ruby-talk / ruby-lang.org (ruby-talk ML)
>Subject: [ruby-talk:10831] Re: RubyChangeRequest #U002: new proper name for 
>Hash#indexes, Array#indexes
>Date: Wed, 14 Feb 2001 15:57:49 +0900
>
>Hi,
>
>Oops, I shouldn't have assigned RCR number by myself.
>
>In message "[ruby-talk:10830] RubyChangeRequest #U002: new proper name for 
>Hash#indexes, Array#indexes"
>     on 01/02/14, Yukihiro Matsumoto <matz / zetabits.com> writes:
>|
>|Hi,
>|
>|I have to admint `indexes' is not good name, since its behavior
>|(returning values corresponded to keys/indexes) not consistent with
>|one of `index' (returning key/index of value).
>|
>|Let's face it.
>|
>|I decided to declare them obsolete and give proper new names in the
>|future (1.7 and forth coming 1.8/2.0).  Do you have any idea of good
>|name for them?
>|
>|I'm not going to remove them, just give warning if you use them.
>
>References: [ruby-talk:8920]
>
>							matz.

lol, matz, you can do ANYTHING you want ;).

Mike Wilson
Unix Administrator
http://ruby.weblogs.com

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com