Lloyd Zusman wrote:
> Although the mutex and monitor classes also can work
> here, I prefer Sync_m in this case because its name reflects the exact
> use to which I am putting it: synchronization.

Except of course that you are in fact doing the exact opposite
of synchronizing - you're *asynchronizing*. Or enforcing MUTual
EXclusion... names mean different things to different people,
you seem to have absorbed the inverted (Java?) meaning of
"synchronize" :-).

Nice little program BTW, thanks for posting it, if inadvertently.

Clifford Heath.