Hello Kevin,

KH> I've been contemplating using Ruby for an upcoming large project, but became
KH> concerned when I learned that the next versions of Ruby (1.9, 2.0) will
KH> include sweeping backwards-incompatible changes (ref:
KH> http://www.rubygarden.org/ruby?Rite). Does this not raise some concern with

Rite is not Ruby 2.0

For some unkown reasons the ruby developers decided that they don't
like two digit version numbers so after 1.9 comes 2.0. But this step
is very smoothly (at least the step from 1.8.1 to the current CVS) so
i think it will not hurt you very much.

And i doubt that ruby will change so much in the future because i
guess that matz company would not be happy if his work breaks to much
existing code.


-- 
 Best regards,                        emailto: scholz at scriptolutions dot com
 Lothar Scholz                        http://www.ruby-ide.com
 CTO Scriptolutions                   Ruby, PHP, Python IDE 's