Hi, 

From: karibou <me / privacy.net>
Subject: tk.update
Date: Tue, 27 Jul 2004 00:21:52 +0900
Message-ID: <2mklm1Fo00tdU1 / uni-berlin.de>
> Please is anyone able to guide me to what I am missing ? tk update seems 
> to have vanished from the Ruby versions after Ruby 1.8.1 eg 
> tktext.update tkentry.update etc. I have an older app complaining about 
> this.

The 'update' method calls Tcl/Tk's 'update' command. 
The command does NOT depend on a widget. So, I think, it isn't 
proper that widget objects have the 'update' instance method. 
If you add the following definition to Tk module or TkWindow class, 
your applications will work. 
--------------------------------------------
  def update(idle=nil)
    Tk.update(idle)
    self  # maybe useful
  end
--------------------------------------------
I'll add the definition to Tk module for backward compatibility. 
But I don't recommend you to use this method. 
-- 
                                  Hidetoshi NAGAI (nagai / ai.kyutech.ac.jp)