On Wednesday, July 21, 2004, 6:22:19 PM, Tanaka wrote:

>> But I do not really care much, readchunk is ok if it works. :)

> Good name is necessary to incorporate a method to ruby.

Here's the relevant bit from the relevant ruby-dev summary:

  TANAKA Akira suggested a new method IO#readpartial, which is
  a better sysread() implementation supporting stdio buffer and
  avoiding troubles due to non-blocking I/O.

Tanaka, can you please give a brief description of the method (assume
I know nothing about advanced I/O), and I'll suggest a name.  Of
course, other people will too.

Gavin