On Tue, 20 Jul 2004 08:03:33 +0900, vruz <horacio.lopez / gmail.com> wrote:
> [snip]
> > I just thought I'd check first that Matz's plan came to be.  Is
> > Onigurama used in 1.9?
>  
> According to:
> http://www.rubygarden.org/ruby?Rite
> Oniguruma would make it in 1.9
> 
> 1.8.2 is due later this month, I'd say it will take
> some months before 1.9.0 sees the light of day,
> maybe in time for the next Rubyconf.
> (pure especulation on my part)

It is my understanding that 1.9 already uses Oniguruma as its default
regexp engine. However, 1.9 is not a "release" version -- and it will
never see the "light of day"; the next "major" version will be 2.0 --
Ruby 1.7 was a dev version; 1.9 is also a dev version. It's like the
Linux kernel releases (2.4, 2.6 are public versions; 2.5 and 2.7 are
dev versions).

-austin
-- 
Austin Ziegler * halostatue / gmail.com
               * Alternate: austin / halostatue.ca