I had freeRIDE working at one time, but now it gives me this:


freeride-0.6.0> sh run.bat
src/emitter.rb:502:in `iconv': cannot convert nil into String (TypeError)
         from src/emitter.rb:502:in `internal_to_utf'
         from src/emitter.rb:817:in `end_object'
         from src/emitter.rb:1175:in `quick_emit'
         from src/emitter.rb:1514:in `to_yaml'
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/readers.rb:70:in 
`save'
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/properties.rb:120:in 
`save'
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/properties.rb:82:in 
`databus_notify'
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/databus.rb:614:in 
`notify'
          ... 8 levels...
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/core.rb:35:in 
`new'
         from 
/home/mortonda/Documents/SoftwareDownloads/ruby/freeRIDE/freeride-0.6.0/freebase/lib/freebase/core.rb:35:in 
`startup'
         from freeride.rb:80:in `startup'
         from freeride.rb:92




I think I uninstalled ruby from original source and installed the suse 
9.1 rpm (and cleaned up, re-installed all pre-requisites)

rpm -qa | grep ruby
ruby-1.8.1-42


Any ideas of what I should be looking for?

--
David Morton