My attempt to install ruby-1.6.2 on alpha-osf4.0d with gcc 2.95.2
failed with the following error:

./mkconfig.rb:44: stack level too deep (SystemStackError)
        from ./mkconfig.rb:29:in `foreach'
        from ./mkconfig.rb:29
gmake: *** [rbconfig.rb] Error 1

Please let me know if you have any suggestions.
Thanks,
Eric