Hi

I am trying to compile ruby for AIX 5.2 but I ran into some problems.
The build I am working with is a stable snapshot of ruby 1.8.1 which is
compiling on our AIX 4.3.3.
When I try to compile the same build on the AIX 5.2 the configure runs ok
but make gives me the
following error:

root@XXXXX:/test/ruby:-> make
        gcc -g -O2   -I. -I.  -c array.c
In file included from ruby.h:670,
                 from array.c:15:
missing.h:81: conflicting types for `memmove'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:153:
previous declaration of `memmove'
missing.h:95: conflicting types for `strcasecmp'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:277:
previous declaration of `strcasecmp'
missing.h:99: conflicting types for `strncasecmp'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:278:
previous declaration of `strncasecmp'
missing.h:103: conflicting types for `strchr'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:147:
previous declaration of `strchr'
missing.h:104: conflicting types for `strrchr'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:149:
previous declaration of `strrchr'
missing.h:112: warning: `struct tm' declared inside parameter list
missing.h:112: warning: its scope is only this definition or declaration,
which is probably not what you want.
missing.h:116: conflicting types for `strstr'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/string.h:150:
previous declaration of `strstr'
missing.h:126: conflicting types for `strtoul'
/usr/bin/../lib/gcc-lib/powerpc-ibm-aix5.2.0.0/2.9-aix51-020209/include/stdlib.h:128:
previous declaration of `strtoul'
make: 1254-004 The error code from the last command is 1.


Stop.

The to machines have the following configuration:

AIX 4.3.3
VisualAge C++ Professional / C for AIX Compiler, Version 5
autoconf-2.53-1
automake-1.5-1

AIX 5.2
g++-2.9.aix51.020209-3
gcc-2.9.aix51.020209-3
autoconf-2.53-1
automake-1.5-1

Does anybody have an idea to what the problem might be? Could it be the
compiler?

_______________________________________________

Lars Kromann - M.Sc.E.E, Intelligent Multimedia
Tingvejen 16F 8600 Silkeborg
Tlf. +45 25132571
sealclub / sealclub.net
www.sealclub.net

_______________________________________________