Hi,

At Thu, 8 Jul 2004 20:06:36 +0900,
Curt Hibbs wrote in [ruby-talk:105566]:
> > No, eban says those environment variables are not need at all.
> > RubyInstaller should just set PATH, but not TCL_LIBRARY.  And
> > RUBY_{TCL,TK}_DLL are used only if tcltklib is compiled with
> > --enable-tcltk_stubs, but RubyInstaller doesn't.
> 
> Good, I like that even better! I will change the installer to not set
> TCL_LIBRARY.

Correction: It couldn't find tk.tcl file when it just is not
set.  It worked by moving tcl/lib/* to lib.

Another issue, there are identical files under samples/sample
and doc/Tcl/Tk-1.8.1/sample, except for several files only in
the former.  Instead, *.{rb,so,lib} underneath lib are
superfluous, since they exist also under lib/ruby/1.8 and never
be used.

-- 
Nobu Nakada