Randy Lawrence <jm / zzzzzzzzzzzz.com> writes:

> Anyone know if Ruby will be updated from 1.6 to 1.8 in the next major
> release of OS X?

I don't know, but there's at least to packages for Panther : 

Fink (fink.sourceforge.net):

% fink list ruby
Information about 3553 packages read in 4 seconds.
     ruby            1.8.0-11     Symlinks to ruby1.8
     ruby16          1.6.8-10     Interpreted, object-oriented scripting la...
     ruby16-dev      1.6.8-10     Ruby 1.6 development library
     ruby16-shlibs   1.6.8-10     Ruby 1.6 shared library
     ruby18          1.8.0-11     Interpreted, object-oriented scripting la...
     ruby18-dev      1.8.0-11     ruby static library
     ruby18-shlibs   1.8.0-11     ruby shared libraries

Darwinports (www.darwinports.org):

% /opt/local/bin/port search ruby
ruby            lang/ruby         1.8.1  Powerful and clean object-oriented \
                                         scripting language
rb-fxruby       ruby/rb-fxruby    1.0.27 Ruby bindings for the FOX GUI Toolkit.
rb-rubygems     ruby/rb-rubygems  0.6.0  a package management framework \
                                         for Ruby

The Darwinports package works fine on my 10.3.x box:

% /opt/local/bin/ruby -v
ruby 1.8.1 (2003-12-25) [powerpc-darwin]     
-- 
?ric Jacoboni, n? il y a 1393019885 secondes