From: Lyle Johnson <lyle.johnson / gmail.com>
Subject: Re: GEM /FXRuby problems
Date: Thu, 8 Jul 2004 09:58:09 +0900

Hi Lyle,

 thank you for your reply ! :)

> On Thu, 8 Jul 2004 08:56:56 +0900, Meino Christian Cramer
> <meino.cramer / gmx.de> wrote:
> 
> >  Output I got
> > 
> >  Attempting local installation of 'fxruby-1.2.0.gem'
> >  extconf.rb:30:in `find_installed_fox_version': couldn't find FOX header files (RuntimeError)
> >          from extconf.rb:155
> >  Error installing gem fxruby-1.2.0.gem: ERROR: Failed to build gem native extension.
> >  Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fxruby-1.2.0 for inspection.
> >    See /usr/lib/ruby/gems/1.8/gems/fxruby-1.2.0/ext/fox/gem_make.out
> > 
> > BUT: FOX is definitely installed under /usr/.
> 
> You've installed fox-1.2.0, or fox-1.0.x? It should be looking for a
> file named "fxver.h" in the /usr/include/fox-1.2 subdirectory if
> you've installed fox-1.2.0.
> 
> > I tried to take a look at
> > /usr/lib/ruby/gems/1.8/gems/fxruby-1.2.0/ext/fox/gem_make.out
> 
> It probably never got that far (i.e. it died trying to configure the build).
> 
> > How ca I proceed. The "final result" should be the successfull
> > installation of aeditor 1.3.
> 
> I would hazard a guess that AEditor depends on the stable releases of
> FOX and FXRuby (i.e. fox-1.0 and FXRuby-1.0) and not the unstable,
> alpha release of FXRuby. But you should confirm this with Simon.
> 

According to the homepage of FOX:

 fox-snapshot.tar.gz (development snapshot).
 fox-1.3.3.tar.gz (LATEST DEV).
 fox-1.2.6.tar.gz (NEW STABLE).
 fox-1.0.52.tar.gz (OLD STABLE).

is Fox-1.2.x the stable one...

 Simon, can you read me ??? :)

 keep hacking!
 Meino