On Thu, 10 Jun 2004 11:13:34 +0900, Gavin Sinclair
<gsinclair / soyabean.com.au> wrote:
> 
> 
> > Thus I support using --version to convey information about RubyGems, as
> > anyone accustomed to command-line tools will expect that.
> 
> Quick follow-up with suggestion.
> 
>   -V, --gem-version       Specify version of gem to perform operation on
>   -v, --version           Show RubyGems version and exit
> 
> I think that's pretty reasonable.  Now what about --rubygems-info?  Keep
> it as it is?  Roll it into --version and get rid of it?
> 
> I favour getting rid of --rubygems-info (it's awkward to type) and just
> having
> 
>   -v, --version           Display RubyGems information and exit
> 
>

I guess I'm not the mob, but I would advocate --rubygems-version
replacing --rubygems-info.  I use the --version flag on a regular
basis, but there is definitely something to be said for consistency
with other tools (which I think would also make the case for doing
away with --help-options in favor of --help.

Chad