gabriele renzi wrote:

> il Wed, 26 May 2004 17:53:20 GMT, Randy Lawrence <jm / zzzzzzzzzzzz.com>
> ha scritto::
> 
> 
>>Hi,
>>
>>We're using Ruby 1.8.1 and would like to use RSA to encrypt data using a 
>>public key from our mod_ruby scripts.
>>
>>But it seems that openssl.rb included with Ruby does not support RSA yet.
> 
> 
> 
> Are you sure ?
> the ruby-doc.org RDoc pages shows that a class cRSA exist, isn't that
> what you need ?

Thanks!  I checked it out after seeing your response.

Unfortunately, the example code snippet doesn't work for cRSA and 
there's virtually no documentation.  I'm new at Ruby so maybe I'm doing 
something wrong.

If you know of a working example, please let me know.

Thanks again.