Mathieu Bouchard <matju / cam.org> writes:

> Second "release" of ArrayMixin 0.2, a future equivalent to Perl's TIEARRAY
> system.

I think this is marvelous stuff (and I'm looking forward to the File
version so we can implement StringFile).

Just a thought. Is there a naming convention we should be using to
differentiate the base methods from the derived methods? I'm note sure 
I see a benefit, but there's something nagging at the back of my mind.

One day I'd love to go through the interpreter and #ifdef stuff out
so we have a truly small base interpreter and then have the rest
written in Ruby. RiR might be slow, but it would be a wonderful
reference implementation.

Thanks for this great work


Dave