Kent Dahl wrote:


> It also looks awfully terse. How about:
> 
>   them = 3.times_collect{ Array.new }
> 
> I think it reads better. "Three times, collect [result of] Array.new".

What about

   them = 3.instances_of { Array.new }

It's certainly more verbose than "of", but I think it reads well and the 
user would understand precisely what to expect as the result.